Sie sind hier: Startseite > Bastelbude > Reparaturen > Geschwindigkeitsanzeige SMART

Letzte Änderung:
03.10.2018, 02:09

 

Geschwindigkeitsanzeige SMART

 

 

 

 

Diese Geschwindigkeits-Anzeigetafel ("Sie fahren... km/h") kam als defekt. Der Selbsttest läuft durch, es wird aber keine Geschwindigkeit mehr angezeigt. 

Mal aufgemacht, und relativ wenig vorgefunden. Etwas Leistungselektronik für die LED-Arrays, ein µC (PIC1673A) und der Geschwindigkeitssensor.

Mal am Geschwindigkeitssensor gemessen, dieser soll 5V aus einem 7805 bekommen, geschaltet über ein Mosfet IRF9530.

"Soll", denn an den Anschlüssen des Sensors war nichts sinnvolles zu messen.

Nachgemessen, der Vbias-Pin des Geschwindigkeitssensors hat gute 10 Ohm gegen Masse, hieße also bei 5V 0,5A. Ob das plausibel ist, kann ohne weitere Infos über den Sensor nicht belegt werden. Die Anzeige läuft aber auf 12V, hieße am 7805 blieben min. 7V hängen, 7V*0,5A sind dann 3,5W, für einen TO220 ohne Kühlkörper zweifelsfrei zu viel. 

 

 

 

 

Also versucht, über den Sensor selbst Infos zu bekommen. Dieser ist mit sehr spärlichen Informationen versehen. Teilenummer 86999, 5VDC, und ein Datecode. 

 

 

Mit der Part No. zumindest einen Hersteller gefunden: Macom. In einer alten Produktübersicht ist die Type wiederzufinden: MA86999. Produktbeschreibung: 

24.125 GHz 3-5 mW Dual IF Output, K-Band VCO, supplied with Microstrip Planar Array Antenna MA86999

Passt. Leider sind dennoch keine weiteren Infos, z.B. aufgenommenen Strom.

Hier mal ein Datenblatt einer aktuellen Type, gleiches Band, gleiche HF-Leistung: 

MACS-007802-0M1RS0 Stereo Doppler Transceiver 24.125 GHz

Dieses gibt den operating current mit 85mA nom. an. Sehr wahrscheinlich liegt der Fehler also in dem Mikrowellen-Transceiver.

Leider haben sich mit RoHS die Part No. bei Macom geändert, diese muss man also auf die neue Type umschlüsseln. Bei einigen neuen Datenblättern steht explizit dabei, welche alte Type sie ersetzen. Für die Part No. MA86999 wird das nicht so einfach, da dieses Teil eine aus Transceiver und Antennenarray ist. Welcher Transceiver dort verbaut ist, weiß wohl nur Macom selbst. 

Selbst wenn die Type bekannt wäre, müsste man noch immer einen Distributor finden, der einem ein einzelnes Teil verkauft...

 

Update:

Bei Ebay USA finden sich diverse Ausführungen, auch relativ günstig. Zum Beispiel 2 Stück Mono-Transceiver für 25 USD. Leider will der Verkäufer aber nicht außerhalb der USA verschicken.

Eventuell ist es auch möglich, eine einzelne Gunn-Diode zu organsieren:

 

 

 

Update 09/2018

Nochmal alles wieder zusammengebaut, und an 12V gehängt. Die Gunndiode wird nur gepulst befeuert. Damit ist die Versorgung über den 7805 doch machbar. Dort scheint der Fehler also nicht zu liegen. 

 

Powered by CMSimple_XH | Template by CMSimple_XH | (X)html | css | Login