Sie sind hier: Startseite > Bastelbude > Reparaturen > Barix Barionet 100

Letzte Änderung:
11.12.2017, 21:02

 

Barix Barionet 100

 

Dieses I/O-Modul für Ethernet scheint relativ interessant zu sein. Einfach mal die

Produktinfo

reinziehen. 

Das Gerät wird auch umgelabelt von der Fa. Neumann Elektronik, und in deren Sprechanlagen eingebaut. Dort heißt es dann "DS-6 I/O Modul", mit der Art. Nr. "4 475 0".

 

 

Ich bekam eines dieser Module als defekt. Die Netzwerkbuchse zeigte Aktivität, die CPU-LED allerdings nicht... 

Aufgemacht, wo möglich an den Elkos die Spannungen kontrolliert. Eingangsspannung, 5V, 3,3V, alles soweit da. 

 

 

Also mal ans Netzwerk gehängt, und per Discovery Tool ins Netzwerk geholt.

Damit meldet sich die Kiste schonmal im Webbrowser. Das Webinterface eigentlich recht interessant aus. Alle I/Os lassen sich prüfen/steuern, und es gibt z.B. auch Temperaturanzeigen für 1-wire Temperaturchips...

Unter Opera funktioniert das Webinterface anscheinend nicht zuverlässig, im Firefox dafür aber problemlos. 

Werden aus dem Webinterface irgendwelche Funktionen, z.B. Relaisausgänge geschaltet, so tut sich im Adapter leider gar nichts. 

 

Auffällig auf der Platine waren zwei 74HC595. Diese saßen in der Nähe der LEDs. Da könnte ein Fehler liegen. Mit dem TDS also einmal die Pins geprüft. An Pin 8 (GND) und 16 (Vcc) liegen aber schöne 5V an. Diese kommen scheinbar über einen LM2675Hinter der Netzwerkbuchse steckt ein SE8117T33

 

Ab jetzt ist es nur noch wildes Raten bei mir. Der µC wäre evtl. noch einmal zu kontrollieren. Das ist ein PIC16F887A

Hier mal VDD gegen GND gemessen, 5V. 

Powered by CMSimple_XH | Template by CMSimple_XH | (X)html | css | Login